Вход для клиентов и партнеров
в начало сайта
Партнерская программаОнлайн демоСкачатьКарта сайта
 

Регламент
Документация
Часто задаваемые вопросы (FAQ)
Решения типовых вопросов
Форум поддержки
Библиотека разработчика

Посмотрите демо-ролики и убедитесь в том, что "Twilight CMS" очень удобна в управлении, понятна и проста.

Бесплатно скачайте "Twilight.Basic", установите на своем компьютере и изучите систему более детально.

Если вам нужно установить "Twilight CMS" на существующий сайт или разработать новый - обращайтесь в отдел интеграции.

 

Ваше имя
Ваш Email
Вопрос
Twilight.basic
  • Узнайте больше
  • Сравните версии
  • Twilight.selection
  • Узнайте больше
  • Сравните версии
  • Twilight.evolution
  • Узнайте больше
  • Сравните версии
  •  
    Главная // Форум поддержки

    Установка Twilight CMS / Установка на Unix (хостинг-площадка) / Не запускается java, в админку не входит

    есть новые сообщения  Время:   31.10.13 17:34
    vidoq java 1.7.0.25
    ось mac os 10.8.5
    браузер сафари 6.1

    при входе в админку (после ввода логина и пароля) дерево сайта (слева) не загружается, консоль java выводит ошибки:
    --------------------------------------------------
    Resource http://www.udmdogs.ru/Bin/bg.gif has future expires: Mon Oct 27 22:29:15 SAMT 2014 update check skipped.
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JLibS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JLibS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JLibS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JLibS.jar
    Lib v.0.14.0
    Tool v.0.2.1
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JLibS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JLibS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JLibS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JLibS.jar
    TreeCtrl v.0.26.0
    [Tool] ERROR: File '/Users/vidoq/TwilightCMS5/TWL_tool.store' not found (yet).
    [Tool] ERROR: Can't create filewriter for '/Users/vidoq/TwilightCMS5/TWL_tool.store'.
      /Users/vidoq/TwilightCMS5/TWL_tool.store (Operation not permitted)
    [Tool] ERROR: Can't save to file /Users/vidoq/TwilightCMS5/TWL_tool.store
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/NanoXMLS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/NanoXMLS.jar
    [Tool] ERROR: Can't create filewriter for '/Users/vidoq/TwilightCMS5/TWL_tool.store'.
      /Users/vidoq/TwilightCMS5/TWL_tool.store (Operation not permitted)
    [Tool] ERROR: Can't save to file /Users/vidoq/TwilightCMS5/TWL_tool.store
    [ProjSettings] ERROR: Folder for '/Users/vidoq/TwilightCMS5/udmdogs.ru.project' is null.
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/NanoXMLS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/NanoXMLS.jar
    [PrivlgFileCreate] ERROR: Can't create file 'Auth.settings'.
      Operation not permitted
    [Auth.settings] ERROR: Can't create file.
    [] ERROR: Can't create FileInputStream.
      /Users/vidoq/TwilightCMS5/Auth.settings (No such file or directory)
    [AuthSett] ERROR: null
    [AuthSett] ERROR: null
    [Settings] ERROR: Can't create new Settings.
      null
    last modified = 0
    [Settings] ERROR: 'settings' object is null (tree).


    до этого удалял папку TwilightCMS5, как видно по ошибкам - воссоздать он ее не может..

    че делать?

    есть новые сообщения  Время:   31.10.13 17:53
    Служба поддержки Обновитесь до последней версии.
    есть новые сообщения  Время:   31.10.13 18:48
    vidoq забыл сказать, у меня текущая 5.24, вроде она же и последняя
    есть новые сообщения  Время:   31.10.13 18:49
    vidoq произошло это тогда когда я java обновил до последней версии, до этого (по моему) релиза 2 я пропустил и все время обновление откладывал.
    видно не зря откладывал.. ((
    есть новые сообщения  Время:   31.10.13 19:29
    Служба поддержки В 5.24 апплеты находятся в подпапках /Bin/Lib/applets6 или /Bin/Lib/applets7, а судя по вашим логам апплеты ищутся по старым путям. Возможно, обновление было установлено некорректно.
    есть новые сообщения  Время:   31.10.13 19:32
    Служба поддержки Хотя нет, мы ошиблись. Там идет речь о путях в манифесте. Судя по логам проблема в ограничении прав апплетам на запись файлов на диск. Последнее обновление явы усложнило в очередной раз работу с системными функциями, но у нас под MacOS пока все работает без проблем. Мы выясняем как это обойти, но пока единственный способ - откатить яву на версию назад, если это возможно.
    есть новые сообщения  Время:   31.10.13 22:02
    vidoq К сожалению, откатить яву назад на маке - не передставляется возможным, видно буду ждать решения..из под параллели буду заходить :(
    есть новые сообщения  Время:   01.11.13 13:43
    vidoq можно откатиться на 6ю яву, вот как тут рекомендовано
    http://support.apple.com/kb/HT5559?viewlocale=ru_RU&locale=ru_RU
    но и с ней не работает :(

    Missing Application Name: manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Application Name: manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Application Name: manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JTreeS.jar
    Missing Application Name: manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Permissions manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    Missing Codebase manifest attribute for: http://www.udmdogs.ru/Bin/JToolS.jar
    java.lang.UnsupportedClassVersionError: JTree/TreeCtrl : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:217)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at sun.plugin2.applet.Plugin2ClassLoader.defineClassHelper(Plugin2ClassLoader.java:1078)
        at sun.plugin2.applet.Plugin2ClassLoader.access$100(Plugin2ClassLoader.java:64)
        at sun.plugin2.applet.Plugin2ClassLoader$2.run(Plugin2ClassLoader.java:1055)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.plugin2.applet.Plugin2ClassLoader.findClassHelper(Plugin2ClassLoader.java:1019)
        at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:130)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:259)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:189)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:249)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:189)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:170)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:721)
        at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:3148)
        at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1536)
        at java.lang.Thread.run(Thread.java:695)
    Исключение: java.lang.UnsupportedClassVersionError: JTree/TreeCtrl : Unsupported major.minor version 51.0
    java.lang.UnsupportedClassVersionError: TWL/Tool : Unsupported major.minor version 51.0
        at java.lang.ClassLoader.defineClass1(Native Method)
        at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)
        at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
        at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
        at java.net.URLClassLoader.defineClass(URLClassLoader.java:217)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at sun.plugin2.applet.Plugin2ClassLoader.defineClassHelper(Plugin2ClassLoader.java:1078)
        at sun.plugin2.applet.Plugin2ClassLoader.access$100(Plugin2ClassLoader.java:64)
        at sun.plugin2.applet.Plugin2ClassLoader$2.run(Plugin2ClassLoader.java:1055)
        at java.security.AccessController.doPrivileged(Native Method)
        at sun.plugin2.applet.Plugin2ClassLoader.findClassHelper(Plugin2ClassLoader.java:1019)
        at sun.plugin2.applet.Applet2ClassLoader.findClass(Applet2ClassLoader.java:130)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:259)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:189)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass0(Plugin2ClassLoader.java:249)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:189)
        at sun.plugin2.applet.Plugin2ClassLoader.loadClass(Plugin2ClassLoader.java:170)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
        at sun.plugin2.applet.Plugin2ClassLoader.loadCode(Plugin2ClassLoader.java:721)
        at sun.plugin2.applet.Plugin2Manager.createApplet(Plugin2Manager.java:3148)
        at sun.plugin2.applet.Plugin2Manager$AppletExecutionRunnable.run(Plugin2Manager.java:1536)
        at java.lang.Thread.run(Thread.java:695)
    Исключение: java.lang.UnsupportedClassVersionError: TWL/Tool : Unsupported major.minor version 51.0

    откатиться на предыдущую версию java 7 например на 1.7.0.21 (как до этого у меня была) нет возможности :(

    есть новые сообщения  Время:   01.11.13 14:13
    vidoq Упс, все же есть.
    Но путь не простой
    сначало нам надо удалить java 7, я делал это как написано тут:
    http://support.apple.com/kb/HT5559?viewlocale=ru_RU&locale=ru_RU
    (тут правда о том как подключить яву 6 вместо 7, но тоже пойдет)

    далее идем по ссылке, регистрируемся и скачиваем 7.21 версию java
    http://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.html#jre-7u21-oth-JPR

    подправив в сафари (версия у меня напомню 6.1) вкладку безопасность - плагины, разрешение на запуск java на сайте в не безопасном режиме - все заработало.

    есть новые сообщения  Время:   09.01.14 17:42
    cotelea Когда ожидается выход обновлённой версии Twilight.CMS коректно работающая с последней версией Java на компьютерах с операционной системой Mac OS? Игра в откаты на более устаревшие версии Java принижает и усложняет работу с смс в глазах моих нынешних и будущих клиентов. Спасибо за понимание.
    Страница: << < 1 2 > >>

    Ваше имя:

    Email:

    Сообщение:

    Прислать оповещение на email, если мне ответят

     
    © 2003-17 Страта Технологии (создание сайтов, разработка cms), Twilight CMS in english.
    Наш адрес: Москва, пр. Маршала Жукова д.51
    Тел.: (495) 222-6436, E-mail: , карта сайта, условия использования информации о CMS
    Звоните через Skype:  

    Реклама: