Вход для клиентов и партнеров
в начало сайта
Партнерская программаОнлайн демоСкачатьКарта сайта
 

Регламент
Документация
Часто задаваемые вопросы (FAQ)
Решения типовых вопросов
Форум поддержки
Библиотека разработчика

Посмотрите демо-ролики и убедитесь в том, что "Twilight CMS" очень удобна в управлении, понятна и проста.

Бесплатно скачайте "Twilight.Basic", установите на своем компьютере и изучите систему более детально.

Если вам нужно установить "Twilight CMS" на существующий сайт или разработать новый - обращайтесь в отдел интеграции.

 

Ваше имя
Ваш Email
Вопрос
Twilight.basic
  • Узнайте больше
  • Сравните версии
  • Twilight.selection
  • Узнайте больше
  • Сравните версии
  • Twilight.evolution
  • Узнайте больше
  • Сравните версии
  •  
    Главная // Форум поддержки

    Установка Twilight CMS / Установка системы на Windows NT / Версия под денвером не работает

    есть новые сообщения  Время:   20.06.06 23:22
    aship Скачал версию для Денвера, все сделал по инструкции. После установки посылает по 500 адресу. Код ошибки:

    Premature end of script headers: /home/demosite/cgi-bin/get.cgi
    Can't locate CGI.pm in @INC (@INC contains: /home/demosite/cgi-bin/lib .) at ./mylib.pl line 60.\\n
    BEGIN failed--compilation aborted at ./mylib.pl line 60.\\n
    Compilation failed in require at \\\\home\\\\demosite\\\\cgi-bin\\\\get.cgi line 6.\\n

    В чем дело?

    есть новые сообщения  Время:   21.06.06 01:01
    Служба поддержки Если все делать по инструкции то никаких проблем не будет. Система многократно тестирована под разными OS, также и в присутствии клиентов у которых были подобные проблемы.

    Проверьте поставили ли Вы пакет библиотек для Perl, который поставляют разработчики Денвера. Читайте описание Денвера. К системе эта проблема не имеет никакого отношения.

    есть новые сообщения  Время:   21.06.06 10:40
    Anonymous Отвечаю, все сделано строго по инструкции.
    Описание денвера прочитано. И более того, я работаю с ним уже полтора года.

    Сайт на вашей CMS не работает.

    Я расчитываю на более конкретный ответ, коль скоро уплатил деньги за вашу CMS и хочу ее использовать.

    Если к системе проблема не имеет отношения, то к чему она имеет?
    Если проблема в нехватке каких-то библиотек, я хотел бы знать, каких именно?

    есть новые сообщения  Время:   21.06.06 13:30
    Служба поддержки Внимательно читайте сообщение об ошибке: отсутствует CGI.pm по путям, которые прописаны в настройках Perl. То есть, Perl не может найти библиотеку CGI.

    Поскольку с Денвером Вы работаете уже давно, вероятно Вы не ставили его "с нуля", согласно инструкции, а пользуетесь какой-то готовой инсталляцией. В таком случае, Ваша конфигурация может отличаться от стандартной. Удаленно предполагать причину мы не можем, поэтому или ставьте все на чистую машину согласно инструкции, или, если Вы опытный разработчик и пользуетесь уже настроенными конфигурациями, ищите причину в своих настройках.

    есть новые сообщения  Время:   21.06.06 21:31
    Anonymous ОК! Скачал свежий Денвер, все сделал заново и стройжайшим образом по инструкции.
    Не работает. Пишет ту же ошибку.

    Внимательно прочитал сообщение об ошибке. Там ничего такого не написано, что вы написали, но допустим дейтсвительно "отсутствует CGI.pm по путям, которые прописаны в настройках Perl. То есть, Perl не может найти библиотеку CGI."

    И что из этого следует?
    Что нужно делать в такой ситуации? Для меня это филькина грамота.

    есть новые сообщения  Время:   22.06.06 01:19
    Служба поддержки Скачали свежий Денвер: Base_2006-04-25_a1.3.31_p4.4.2_m4.1.16_pma2.6.1.exe
    Пакет для Perl у разработчиков со времени наших последних тестов не менялся: 2002-11-26_ActivePerl5.6.1.exe

    Прошли все шаги согласно нашей инструкции на чистой Windows XP Professional SP2.

    При установке Денвера используем все ключи по умолчанию (хотя и указание других путей дял установки также работает нормально), кроме варианта запуска виртуальных дисков - обычно мы тестируем в режиме 2 (создавать диски не при запуске OS).

    Сайт заработал без всяких проблем.

    Ищите проблему у себя локально. Видимо, что-то блокирует нормальную установку Денвера и пакета расширения для Perl и библиотеки недоустановились. Либо Вы указываете при установке такие ключи, которые портят переменные окружения для системы и она не может найти корректно установленные библиотеки.

    Можете обратиться к службе поддержки Денвера. В частности поиск в Google дает следующие обсуждения, которые похожи на Вашу проблему:
    http://forum.dklab.ru/viewtopic.php?p=56973&sid=75fff02c9ea55470a7f6fba8662744c2
    http://forums.webscript.ru/showthread.php?s=1adcf6479dd69a09b2518e155dd25c2f&threadid=13830


    Ваше имя:

    Email:

    Сообщение:

    Прислать оповещение на email, если мне ответят

     
    © 2003-17 Страта Технологии (создание сайтов, разработка cms), Twilight CMS in english.
    Наш адрес: Москва, пр. Маршала Жукова д.51
    Тел.: (495) 222-6436, E-mail: , карта сайта, условия использования информации о CMS
    Звоните через Skype:  

    Реклама: